Connectivity issues for some users
Incident Report for Tidio
Resolved
Everything is running smoothly again and we have stopped receiving reports from Mexico. Thank you for your patience.
Posted about 1 year ago. Apr 12, 2018 - 05:06 UTC
Investigating
We are currently investigating a connectivity issue that occurs for users from Mexico. We’ll have more information soon.
Posted about 1 year ago. Apr 11, 2018 - 20:20 UTC