Server issue
Incident Report for Tidio
Resolved
There has been an error associated with one of our external server providers; we apologise for the downtime. It has now been resolved and everything should be back to normal.
Posted almost 2 years ago. Nov 09, 2017 - 08:06 UTC
Investigating
We’re currently investigating server issues. Please bear with us while our engineers are working to fix this. Many apologies.
Posted almost 2 years ago. Nov 09, 2017 - 07:28 UTC