Connectivity issues for some users

Incident Report for Tidio

Resolved

Everything is back up and running. Thank you for your patience
Posted Apr 17, 2026 - 21:41 UTC

Update

A third party service is currently monitoring the situation - a fix has been implemented and they are monitoring the results. We are observing mixed outcomes for our users and appreciate your patience as we work to resolve this.
Posted Apr 17, 2026 - 19:22 UTC

Investigating

We are currently investigating a connectivity issue that occurs for some users. We’ll have more information soon.
Posted Apr 17, 2026 - 16:07 UTC
This incident affected: Agent Dashboard and Web & Desktop application.