Outage of Meta business products

Incident Report for Tidio

Resolved

Meta has resolved the issues affecting their business products, including WhatsApp, Facebook, and Instagram. All services are now fully restored and operating normally.
Posted Jun 12, 2026 - 18:26 UTC

Identified

Meta has reported issues affecting some of their business products, including WhatsApp, Facebook, and Instagram. You can follow live updates directly from Meta on their status page here: https://metastatus.com/
Posted Jun 12, 2026 - 14:45 UTC
This incident affected: Web & Desktop application.