Connectivity issues for some users
Incident Report for Tidio
Resolved
Our developers managed to rectify the problem. The service is back up and running.
Posted 3 months ago. Jul 18, 2019 - 21:23 UTC
Identified
We found that there's a connectivity issue in some areas, our developers are working on rectifying the issue.
Posted 3 months ago. Jul 18, 2019 - 21:19 UTC
This incident affected: Web & Desktop application.