Issues with Emails sent via Tidio
Incident Report for Tidio
Resolved
This incident has been resolved.
Posted Oct 23, 2023 - 12:56 UTC
Update
We are continuing to investigate this issue.
Posted Oct 23, 2023 - 12:56 UTC
Investigating
We're currently investigating problems with sending Emails via Tidio.
Posted Oct 23, 2023 - 11:34 UTC
This incident affected: Web & Desktop application.